Announcement

Collapse
No announcement yet.

Buttons for Other Languages

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Buttons for Other Languages

    I've downloaded the German language pack, and want to install it alongside the English sections of my forum.

    So far I've got things working as I need. What I am puzzled over is how to get the German buttons working.

    So far I've tried installing them in the root vb install folder as images_german and also inside the images folder.

    But, nothing I do is showing them up. I'd heard that this might be a problem.

    Is there a way of setting it up so that I can use the buttons simultaneously without having to install a new theme dedicated to the language?

  • #2
    You need to set this to the appropriate directory:

    Admin CP -> Languages & Phrases -> Language Manager -> Edit Settings -> Image Folder Override
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      What format does the image folder need to be? i.e.

      /imagefolder/
      or
      imagefolder/

      ?

      Comment


      • #4
        I believe this will work, assuming it is a subdirectory of your main forum directory:

        imagefolder/
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Nope. The forum is setup in a subdirectory, so I've tried several variations:

          image_german/
          /image_german/
          /image_german (like in the Styles setting)

          As well as adding the 'forums' subdomain in at the front in similar ways to above.

          Comment


          • #6
            Then you will neeed to use the full and exact path to that directory on the server. On Unix/Linux systems you can find the complete path name by telnetting or sshing into your server, going to that directory and typing:

            pwd
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              That didn't work either, so I had the idea to check what the actual HTML was reading as.

              From that I noticed that it was trying to find the 'buttons' folder. So I created both the direct path, and the relative path and both picked up the buttons folder and the appropriate images.

              So...

              Code:
              /forums/images_german/buttons/
              That connected me to the new buttons.

              What I am confused about is the instructions on the inline help:

              Image Folder Override Use this to override the images folder associated with the style being used. You may use <#> to represent the style ID the user is currently using
              Serveral vBulletin images have language-specific text in them. This option lets you use images made for a different language.

              You may use <#> to represent the style ID the user is currently using. This allows you to support different styles for this language. For example, you can name the images folder something like images_name of language_style ID of style and then set this setting to images_name of language_<#>
              It might be worth in the next up date (perhaps) adding in that it relates to the buttons folder only.

              Thanks for the help. Glad it's sorted now...

              Comment


              • #8
                Thanks quasar: i had this same problems since some days ago 'cause I thought that the Image Folder Override was about override ALL the image folder.

                Now it works in my spanish forum.
                Thanks again!
                Mauricio Solano R. - Costa Rica
                Vote for fix the double word issue

                Comment


                • #9
                  Glad you got it sorted. Nice to be able to help in some way.

                  Comment


                  • #10
                    Thanks!

                    Originally posted by quasar View Post
                    Glad you got it sorted. Nice to be able to help in some way.
                    Thanks from my site too! Your way worked out!

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X