Announcement

Collapse
No announcement yet.

New language pack overwriting my english phrases

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The solution is to get the author of that pack to change it so it's not a master language pack.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #17
      But it is not a master language pack!

      here is the header from the xml file:

      Code:
      <language name="Greek" vbversion="3.5.0" product="vbulletin" type="custom">
      This is the file: http://www.vbulletin.com/forum/attac...0&d=1133464404

      I know the language file is for vbulletin 3.5.0, and i tried a clean install of 3.5.0 and then imported the file, its exactly the same result. Some english phrases get overwriten, most of them (if not all) being GLOBAL or Control Panel Global phrase type.

      Comment


      • #18
        Then sorry, I don't know what to tell you. You will need to contact the author of that pack for help with this.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #19
          I would suggest you guys ONLY install language packs made for YOUR VERSION of vBulletin ONLY.

          I installed Spanish, French and Hebrew on my forums. They added alot of phrases to GLOBAL which overwritten other phrases on the board. I spent a whole day manually removing them from the Database, they all had languageid 0, which im assuming its for custom phrases, as the master language is -1.

          When you install a language pack different from your vB version when it finds phrases that the master language doesnt have it creates custom phrases that you later have to remove one by one using the AdminCP, or using the Database. Cleaning my board from weird Hebrew phrases was a pain. And im still afraid I may have messed up my language system on the cleaning.
          Radio and TV Player for vBulletin

          Comment


          • #20
            Originally posted by Dream View Post
            I would suggest you guys ONLY install language packs made for YOUR VERSION of vBulletin ONLY.
            Good advice but I installed German some time ago and the problems started when I upgraded VB from 3.5x to3.6x

            Has anyone had any success with restoring the defaults in places like Admincp etc? So far I have been searching and replacing as I find them
            Rick Grunwald
            http://grunwalds.com
            XP home SP2, Celeron 2gb, 2GB RAM, Zone Alarm Security Suite

            Comment


            • #21
              Originally posted by Dream View Post
              I would suggest you guys ONLY install language packs made for YOUR VERSION of vBulletin ONLY.
              That gives two major problems:
              A) With some languages on my site, there are no completely written language packs in any version of vB, I had to create my own for Slovenian, and other packs for common languages, e.g. Portuguese are quite incomplete.

              B) The solution above CREATES the original porbem of this thread. If you make your own FAQS on a disrelated subject to vBulletin, and install any updated language pack in that language, all your personally created FAQs will get deleted from your site without warning.

              E.g. if you create a FAQ about the need for repairing your car in German, and you decide to change your vBulleting from German Formal to Informal (which will only change "Sie" to "du" in your vB help files, all your FAQs about car maintenance will be wiped off your site.

              Quite a problem for somebody with several custom FAQs in 6 languages.

              So once you have created your own FAQS that you want to keep, you must not update with the current language packs, but manually translate the outdated phrases for the new version yourself.

              I would appreciate if somebody has found a workaround for this problem, e.g. has anybody had luck copying their old (but current) custom made FAQs into the XML file of an updated language pack before instaling it?
              22nd century Shamanism
              www.antostm.com

              Comment


              • #22
                I wish I read up on this before I decided to install some language packs.

                Overwritten some of the English phrases and now my board is looking pretty bad. It's a relatively popular board too...I have no idea what to do.

                I am hoping I can restore the phrase table in my database in mySQL. I'm not really sure how to do that though..

                Comment


                • #23
                  Originally posted by RidinHighSpeeds View Post
                  I wish I read up on this before I decided to install some language packs.

                  Overwritten some of the English phrases and now my board is looking pretty bad. It's a relatively popular board too...I have no idea what to do.

                  I am hoping I can restore the phrase table in my database in mySQL. I'm not really sure how to do that though..
                  Originally posted by Chousho View Post
                  In the zip file of the VB release you should find an xml file named vbulletin-language.xml in the install folder. Try uploading that. It's been a while, but I remember just uploading the default language over and having it work.
                  Just upload that file (vbulletin-language.xml) through admin cp as master language, etc etc.

                  Comment


                  • #24
                    Originally posted by Chousho View Post
                    Just upload that file (vbulletin-language.xml) through admin cp as master language, etc etc.
                    Did it successfully, but for some reason there are many phrases that are still in German.

                    activate is Activer
                    activatity is vActivité



                    and so on...

                    Comment


                    • #25
                      Originally posted by RidinHighSpeeds View Post
                      Did it successfully, but for some reason there are many phrases that are still in German.

                      activate is Activer
                      activatity is vActivité



                      and so on...
                      That's french not german

                      But to be on topic, after upgrading from 3.5.4 to 3.6.4 I have also a lot of untranslated phrases but can't upgrade the language files because they overwrite my custom changed or additional created phrases and there's no way except to do it manually. There should be an option in the phrases system to import only new phrases or keep changed/custom phrases.
                      .......

                      Comment


                      • #26
                        I went into phpMyAdmin and noticed something:

                        In the phrase table:

                        languageid smallint (6)
                        varname varchar (250) latin1_bin
                        text mediumtext latin1_swedish_ci
                        product varchar(25) latin1_swedish_ci

                        and so on...

                        The rest are all swedish...

                        What is the English list supposed to look like?? If you could tell me what values to change those too, I would greatly appreciate it. I think that might be the problem

                        Comment


                        • #27
                          That's because when you created the table, it set those by whatever the default was. A language pack won't update the encoding of a table.

                          Comment


                          • #28
                            Makes sense..

                            I did a SQL query for languageid=0 and deleted most of the stuff that I did not recognize (foreign)

                            It looks like some of the phrases varnames were the same as the English varnames...So I simply deleted all the ones that were foreign to me, then rebuilt the English Language in ACP.

                            Everything is working properly once again.

                            Thank God!

                            Comment


                            • #29
                              Originally posted by Chousho View Post
                              That's because when you created the table, it set those by whatever the default was. A language pack won't update the encoding of a table.
                              My "fresh install" was English. I had added German, Polish and Sweedish language packs. The German is the only one that started giving trouble after upgrading to 3.6.x (x probably equals "4")

                              I keep finding phrases in the admin CP and on the board itself in German. I have been hunting them out individually and correcting them as uploading the oringinal language XML file did NOT work. I suppose uploading it as a new language and deleting the old language may have done something but I didn't want to destroy the German translation in the process
                              Rick Grunwald
                              http://grunwalds.com
                              XP home SP2, Celeron 2gb, 2GB RAM, Zone Alarm Security Suite

                              Comment


                              • #30
                                Maybe a late answer, but i had the same problem with v3.8.4 patch 1.
                                I installed the German language and my ACP turn also to this language.
                                I can understand it, but my English is a little better.
                                I searched and came to this topic, but no descent answer.
                                Then i came to think of it, that i installed it from my harddisk and the official language should be in the program itself.
                                I uploaded the original language-pack from /upload/install/vbulletin-language.xml and now it's all fixed.
                                I know now, that i have to be carefull with language-packs.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X